EntryClient

EpiData Entry Client is the new program for data entry, with support for multiple platforms and operating systems.
Tasklist

FS#167 - afterRecordState is not respected

Attached to Project: EntryClient
Opened by Jamie Hockin (jhockin) - Friday, 10 February 2017, 00:17 GMT
Last edited by Torsten Bonde Christiansen (torstenchr) - Friday, 04 August 2017, 09:26 GMT
Task Type Bug Report
Category Other
Status Closed
Assigned To Torsten Bonde Christiansen (torstenchr)
Operating System All
Severity Medium
Priority Normal
Reported Version 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In v4, with a dataform property that includes afterRecordState="arsReturnToParent"
on saving the form, control goes to another subform. In my testing, all subforms have only a single instance allowed.
Setup is
Main
->sub 1
->sub 2
->sub 3
->sub 4

After entering sub 1, we go to sub 2, then sub3 and sub 4
After entering sub 2 without a sub 1, we go to sub 1
This task depends upon

Closed by  Torsten Bonde Christiansen (torstenchr)
Friday, 04 August 2017, 09:26 GMT
Reason for closing:  Not a bug
Comment by Jamie Hockin (jhockin) - Friday, 17 February 2017, 22:34 GMT
Not a bug!!! The properties of the main dataform were left as the default (Continue to sub1, sub2, sub3, sub4). Removing all of these restores expected action.

Loading...