EntryClient

EpiData Entry Client is the new program for data entry, with support for multiple platforms and operating systems.
Tasklist

FS#173 - Focus transferred to the next field before the field is full

Attached to Project: EntryClient
Opened by Jean-Marie Chr├ętien (jmchretien) - Friday, 30 June 2017, 12:53 GMT
Last edited by Torsten Bonde Christiansen (torstenchr) - Friday, 04 August 2017, 09:09 GMT
Task Type Bug Report
Category Other
Status Closed
Assigned To Torsten Bonde Christiansen (torstenchr)
Operating System Windows
Severity Medium
Priority Normal
Reported Version 4.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Identified in version 4.2.0.0 and below

I have a field defined with only one digit in the "decimal" part and three digit in the "length" part.

In the epidata entry client, when the user enter "123," a zero is automatically added when "," is entered and the focus is transferred to the next field.

This only occurs when the total number of characters entered by the user is equal to "length"+"decimal" and only for fields with one decimal.

If the user enter "1,2" it's ok.
It's quite disturbing for our users.
This task depends upon

Closed by  Torsten Bonde Christiansen (torstenchr)
Friday, 04 August 2017, 09:09 GMT
Reason for closing:  Not a bug
2017-08-31: A request to re-open the task has been made. Reason for request: Hello, thank for your commentary but it does not solve my question. I think my explanations were not clear enough. So I prepared an epx file to demonstrate the problem. You will find below the XML definition of the field on wich the problem occurs I can sent to you the epx files. <Field id="V1" top="38" left="194" type="ftFloat" length="4" decimals="1" entryMode="emDefault" showValueLabel="true"> <Question> <Text xml:lang="en">Float 2.1 (total lenght 4 car)</Text> </Question> </Field> Best regards
Comment by Torsten Bonde Christiansen (torstenchr) - Friday, 04 August 2017, 09:08 GMT
The confusion is that the Length specifier for float is the "whole" length of all character and that the decimal part is (partly) optional.

So if you have a float variable with length 3 and decimals 1 then effectively the data may look like:
123
112
1,2
,23

Loading...