Manager

Manager program.
Tasklist

FS#174 - Faulty CSV export of memo fields containing LF character

Attached to Project: Manager
Opened by Jean-Marie Chrétien (jmchretien) - Friday, 30 June 2017, 13:16 GMT
Last edited by Torsten Bonde Christiansen (torstenchr) - Friday, 04 August 2017, 08:06 GMT
Task Type Bug Report
Category Functionality
Status Closed
Assigned To Torsten Bonde Christiansen (torstenchr)
Operating System All
Severity High
Priority Normal
Reported Version 4.0
Due in Version 4.2.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I used the new memo field. It's a really good thing.

During input it is possible to add a new line using CTRL+ENTER. It's a nice feature. But, when I export the data in CSV, the hard return introduced are not removed and line break occurs in the output file. The file cannot be imported in our statistic tools.

This occurs in the 4.0.2.101.
Not reproduced in 4.2 because export is actually broken in 4.2
This task depends upon

Closed by  Torsten Bonde Christiansen (torstenchr)
Friday, 04 August 2017, 08:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in Core rev. 1418
Fixed in Manager rev. 1440
Comment by Torsten Bonde Christiansen (torstenchr) - Friday, 04 August 2017, 08:05 GMT
  • Field changed: Due in Version (Undecided → 4.2.1)
We have added an option in preference for CSV export as to what character should replace a linefeed during export.

Default value is space.

Loading...