Core Library

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Test module
  • Assigned To
    Torsten Bonde Christiansen
  • Operating System All
  • Severity High
  • Priority High
  • Reported Version Pre 1.0
  • Due in Version 1.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Core Library
Opened by Jamie Hockin - 27.04.2011
Last edited by Torsten Bonde Christiansen - 29.04.2011

FS#83 - Cannot open a file just created in Manager

I have just created a new project (hotelob.epx), with a small number of fields and headings and I cannot re-open it in either Manager or Entry. I've attached the project. Projects I created earlier seem to work, except for every version of the attached that I have created in the past month. I was able to work with these files earlier. This problem seems to have started with a critical failure of Entry earlier this week (bug report entered), but I reinstalled everything today.

This is a critical issue as we are teaching with this data in 5 weeks. I have to decide whether to use EpiData Manager/Entry or the old versions.

I will try this file out on my old PC.

A smaller project I created today works fine (testdates.epx)
Jamie

Closed by  Torsten Bonde Christiansen
29.04.2011 09:49
Reason for closing:  Fixed
Additional comments about closing:  See previous comment.
Jamie Hockin commented on 27.04.2011 16:13

Oh yes, the error message from Manager and Entry is:
Unable to open the file: /...../hotelob.epx
An unknown error occurred.

Jamie Hockin commented on 28.04.2011 02:51

I get the same problem on my PC with this project - both with the Project file I created on my Mac and when I recreate it on my PC (Windows XP).

However, I have no problem creating and re-opening a Project when I import the data from .rec. All of the fields, headings, value labels and data come through perfectly. I'm just afraid that I'm doing something wrong when I create a project from scratch, but I just cannot see what.

Jamie Hockin commented on 28.04.2011 14:34

The OSX Console shows the following error notice when failing to load my .epx file in Manager:

FindCarbonFontID Error: ATSUFindFontFromName failed with result -8796
(That might be a message related to the error dialogue box, though)

I always get a few of the following notices, but the one above is unique to this "unknown error"
TCarbonTabsControl.SetFocus Error: SetKeyboardFocus failed with result -30585

Jamie Hockin commented on 28.04.2011 19:22

Torsten - today, I can make a Project with no problem. I don't get it at all. I haven't tried on my PC and I didn't make the file exactly the same (e.g. no headings except at the top). Please don't spend a lot of time on this. Here is the file I created today.

Admin
Torsten Bonde Christiansen commented on 29.04.2011 09:46

Moving this bug report to Core project - this issue is related to loading and saving files, common in Core to all programs.

Admin
Torsten Bonde Christiansen commented on 29.04.2011 09:49

The issue has been indentified ind the part of Core where records are loaded (regards of the actual number of records, which could be 0).

Apparently this ONLY occurs when exactly 13 fields are present in the project, no other cases have been discovered.

The problem is solved in revision 428, and should no longer occur for any number of field in a project.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing